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1   Introduction to the Scenarist Tutorial

The Scenarist Tutorial is an introduction to creating DVD-Video discs with Scenarist. It 

takes you step-by-step through the authoring process of importing media files (assets), 

creating movies and menus, adding links between the content, setting playback order, and 

outputting to CD-R, DVD-R, or DLT. The tutorial takes approximately two hours and provides 

an opportunity to use many of the features in Scenarist.

If during the tutorial you have any questions, refer to the Scenarist User Guide or the online 

help. References to chapters in these documents are provided throughout the tutorial.

The rest of this chapter provides the following introductory sections:

• “The Tutorial Project Plan” on page 2

• “The Basic Tutorial Steps” on page 3
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The Tutor ial  Project  Plan

The completed tutorial project will consist of a video feature, slide show, and several motion 

and still menus. Playback will begin with a short Intro Movie that leads directly into the 

Main Menu. The Main Menu is a 10-second video loop containing four menu buttons that 

link to the:

• Main Movie, a video feature (lasting 2 minutes, 30 seconds) with three chapters, audio, 

and subtitles.

• Chapter Menu, a 10-second video loop with three buttons that link to the chapters in the 

Main Movie, and one button that links back to the Main Menu.

• Slide Show, a 40-second slide show with four images and audio.

• DVD Credits, a still menu with one button that links back to the Main Menu.

The project flow for the tutorial is illustrated in Figure 1, where gray boxes represent a 

menu with buttons and white boxes represent a linear sequence (video or slide show). 

Figure 1: Flowchart of the project plan
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The linear sequences will be authored to return to the Main Menu after playback completes. 

The Main Menu will serve as the title menu and therefore be associated with the TITLE 

button on the remote control. The Chapter Menu will serve as the Root Menu for the Main 

Movie and be associated with the MENU button on the remote control.

The Basic  Tutor ial  Steps

The Scenarist Tutorial includes the following basic steps:

1 Prepare the tutorial asset files.

2 Launch Scenarist and create a new scenario using the Default NTSC template.

3 Register tutorial assets by dragging video files, still images, audio files, and subpictures 

from Windows Explorer to the Data Editor.

4 Create tracks by dragging video and still image assets from the Asset Manager to the Track 

Editor. Add audio and subpicture streams by dragging assets to the Track Editor timeline.

5 Import subtitles to the Main Movie from the subtitle script file.

6 Add button highlights to menu tracks in the Simulation window.

7 Create PGCs by dragging tracks from the Asset Manager into language and title folders in 

the Scenario Editor. Add navigation links to set playback order, loop menus, and link 

menu buttons.

8 Proof the project in the Simulation window. Check playback order, test remote control 

interaction, navigate each of the button highlights, and verify link destinations.

9 Output the disc image to CD-R, DVD-R or DLT.

These steps are covered in detail in the remaining chapters. For more information about 

Scenarist workflow, see Chapter 2, “Workflow and Work Areas” in the Scenarist User Guide.
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2   Registering the Tutorial Assets

Assets are the media files used in Scenarist to create tracks and PGCs, which in turn are used 

to build the DVD-Video project. Assets include video files, still images, audio clips, and 

subtitles. This chapter documents preparing the tutorial assets and importing them to a new 

scenario. It includes the following topics:

• “Preparing the Tutorial Assets” on page 6

• “Creating a New Scenario” on page 7

• “Registering the Tutorial Assets” on page 10
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Preparing the Tutor ial  Assets

Before launching Scenarist, you must copy the tutorial assets (included on the Scenarist 

Tutorial disc) to a local hard drive and clear their Read-only attribute. In addition, you must 

edit the subtitle script file to reference the new location for the subtitle images.

To prepare the Scenarist tutorial asset files:

1 Insert the Scenarist Tutorial disc and drag the “Scenarist Tutorial Assets” folder to a local 

hard drive. Make sure the hard drive has enough free space (at least 200 MB).

2 Clear the Read-only Attribute for the copied assets:

• Right-click the copied tutorial folder and choose Properties from the pop-up menu. The 

Properties window opens.

• Deselect the Read-only Attribute and click OK.

• When prompted to confirm the attribute changes, select “Apply changes to this folder, 

subfolders and files,” then click OK.

3 Edit the subtitle script file to update the directory it will reference:

• Locate the subtitle script file (Scenarist Tutorial Assets\Subtitles\Subtitle_Script.sst) and 

Right-click it.

• Choose Open With from the pop-up menu, then from the list of programs, choose 

Notepad and click OK.

• Edit the following Directory line so the folder’s new location is listed.

Directory            C:\Scenarist Tutorial Assets\Subtitles

Scenarist will use this directory to determine where to find the subpicture images that 

make up the subtitle stream. If an incorrect path is entered, Scenarist will not be able to 

import the subtitles.

• Choose FIle > Save to save the changes. Close Notepad.

You are now ready to proceed to the next section and begin creating the scenario. 
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Creat ing a  New Scenario

After preparing the tutorial assets, you are ready to import them to a new scenario. The 

following procedure documents launching Scenarist and creating a new scenario based on 

one of the default templates.

To launch Scenarist and create a ne w scenario:

1 From the Windows Start menu, choose Programs > Sonic > Scenarist > Sonic Scenarist. 

The Project Manager window opens.

2 Click New. The New Project Setup dialog opens.

3 Select Default NTSC and click OK. The Scenarist main window opens displaying the Data 

Editor. 

The Scenarist main window (see Figure 2 on page 8) has four tabs that access the main 

work areas: Data Editor, Track Editor, Scenario Editor, and Layout Editor. There are three 

additional windows (Asset Manager, Information window, and Property Browser) that can 

be displayed either at the bottom of the Scenarist main window or as separate windows 

when undocked. 
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For more information about creating new scenarios (as well as project templates), see 

Chapter 4, “Creating Scenarios” in the Scenarist User Guide. For information about the 

different Scenarist windows, see Chapter 2, “Workflow and Work Areas” in the Scenarist 

User Guide.

Figure 2: Scenarist main window displaying Scenario Editor
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About Scenarios

Scenarist projects are saved in documents called scenarios (.scn). Scenarios contain 

information about the project’s assets (video, still images, audio, and subtitles), menu and 

track properties, project layout (PGCs, links, and navigation commands), and disc 

information and disc layout. Saved with each scenario is a cache folder (<Project Name> 

Cache) that contains encoded still images (.mps), encoded subpictures (.sp), and subtitle 

images (.bmp) created in Scenarist. A scenario’s registered assets remain in their original 

hard drive locations.

The default directory for saving scenarios is the My Scenarios folder, which is created on the 

system hard drive when installing the Scenarist software.

Note: Unlike most software applications, Scenarist dynamically saves scenarios. Each time 

you make a change to a project, it is saved to the scenario file. While this ensures that the 

changes you make to a scenario are always retained, it requires that you use the Save As 

command when revising scenarios that you don’t want to permanently overwrite.

My Scenarios folder
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Register ing the Tutor ial  Assets

Assets can be registered in Scenarist by dragging them from Windows Explorer to the Data 

Editor. Before adding the assets to the tutorial project, you will first create asset folders to 

hold the project’s slide images, subpictures, and audio files. The video and menu assets will 

reside in the parent (Data) folder.

This section includes the following topics:

• “Creating the Tutorial Asset Folders” on page 10

• “Registering the Tutorial Asset Files” on page 11

Creating the Tutorial Asset Folders

To create the tutorial asset folders:

1 In the Scenarist main window, click the Data Editor tab to display the Data Editor.

2 In the Data Editor directory area, select the Data folder and choose New > Folder, or 

click the New Folder button in the Tools Bar. 

3 When prompted, enter “Slides” for the name for the new asset folder and click OK. The 

new asset folder is created and appears in the directory area and work area.

4 Repeat the previous steps to create additional asset folders titled “Subpictures” and 

“Audio.”
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Registering the Tutorial Asset Files

To register the tutorial asset files:

1 In the Scenarist main window, click the Data Editor tab to display the Data Editor.

2 In Windows Explorer, open the Scenarist Tutorial Assets folder copied to your hard drive.

3 Drag the following video files from Windows Explorer into the Data folder in the Data 

Editor directory area. The assets are registered and appear in the Data Editor directory 

area and work area. 

Main_Menu
Chapter_Menu
Intro_Movie
Main_Movie
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4 Drag the following still image files from WIndows Explorer into the Slides folder in the 

Data Editor directory area.

Slide_A
Slide_B
Slide_C
Slide_D

5 When prompted to specify the type of object to create, select Still Images and select the 

Apply To All option, then click OK. The assets are registered and appear in the Data 

Editor work area.

6 Drag the following still image files from WIndows Explorer into the Subpictures folder in 

the Data Editor directory area.

Chapter_Menu_Sub
Main_Menu_Sub

7 When prompted to specify the type of object to create, select “Sub-picture with Forced 

Start” and select the Apply To All option, then click OK. The assets are registered and 

appear in the Data Editor work area.

8 Drag the following audio files from WIndows Explorer into the Audio folder in the Data 

Editor directory area. The assets are registered and appear in the Data Editor work area.

Main_Movie_Audio
Slide_Show_Audio

For more information about working with assets (as well as place holders), see Chapter 5, 

“Registering Assets” in the Scenarist User Guide.



               
3   Creating the Tutorial Tracks

This chapter documents how to create the tutorial’s movie tracks, slide show track, and 

menu tracks by dragging assets from the Asset Manager to the Track Editor. It includes the 

following topics:

• “The Intro Movie Track” on page 14

• “The Main Movie Track” on page 15

• “The Slide Show Track” on page 18

• “The Main Menu” on page 20

• “The Chapter Menu” on page 25

• “The DVD Credits Menu” on page 29
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The Intro  Movie  Track

In this section you will create the Intro Movie track, which is this first thing the viewer will 

see when playing the tutorial project. The Intro Movie track will contain a video stream only 

(no audio and no subtitles).

To create the Intro Movie track:

1 In the Scenarist main window, click the Track Editor tab to display the Track Editor.

2 In the Asset Manager, click the Data tab to display the project’s assets.

3 Drag Intro_Movie from the Asset Manager into the Tracks folder in the Track Editor 

directory area. A video track is created.
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The Main Movie  Track

In this section you will create the Main Movie track, which will contain video, audio, and 

subtitle streams, as well as three scenes that will link to the Chapter Menu. 

This section includes the following topics:

• “Creating the Main Movie Track” on page 15

• “Importing Subtitles to the Main Movie Track” on page 16

• “Adding Scenes to the Main Movie Track” on page 17

Creating the Main Movie Track

To create the Main Movie track:

1 In the Scenarist main window, click the Track Editor tab to display the Track Editor.

2 In the Asset Manager, click the Data tab to display the project’s assets.

3 Drag Main_Movie from the Asset Manager into the Tracks folder in the Track Editor 

directory area. A video track is created.

4 In the Track Editor directory area, select the Main_Movie-t track. The timeline displays 

the track’s video and scenes streams.



 

16 Chapter 3, Creating the Tutorial Tracks

           
5 In the Asset Manager, open the Audio folder to display the tutorial’s audio assets. 

6 Drag Main_Movie_Audio from the Asset Manager into the timeline area, just below the 

video stream. The audio stream is added to the track.

Importing Subtitles to the Main Movie Track

In this section subtitles will be added to the Main Movie track by importing a subtitle script 

file that references individual subtitle images.

To import subtitles to the Main Movie track:

1 In the Track Editor directory area, select the Main_Movie-t track.

2 Choose Tools > Import Subtitles. The Subtitle Import dialog opens.
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3 Select Stream 1 (if it is not already selected), then click the File Path button for Stream 1. 

An Open dialog opens.

4 Navigate to and select the Subtitle_Script.sst file (in the Subtitles folder within the Scenarist 

Tutorial folder) and click Open.

5 Click Start.

6 When prompted that the operation may take a while to complete, select Yes and then 

click OK. The subtitles are imported to a new subtitle stream in the track.

7 Click Close to close the Subtitle Import dialog.

For information on creating subtitles within Scenarist, see Chapter 7, “Adding Subtitles and 

Closed Captioning” in the Scenarist User Guide.

Adding Scenes to the Main Movie Track

Scenes, or chapter stops, link to specific locations within video tracks. In this section you 

will add two scenes to the Main Movie track that will be accessible by the viewer from the 

Chapter Menu or with the NEXT and PREVIOUS buttons on the remote control.

To add scenes to the Main Movie track:

1 In the Track Editor directory, select the Main_Movie-t track. The track’s streams are 

displayed in the timeline. 

2 In the scene stream, drag the Time indicator to approximately 00:01:04:00. Use the 

Timecode field in the Tools Bar to monitor the Time indicator location.

Note: If necessary, you can zoom in with the Zoom In button to provider finer 

resolution when dragging the Time Indicator.
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3 Choose New > New Scene or click the New Scene button in the Tools Bar. A scene is 

added to the track and an icon with a time location and thumbnail appears in the scenes 

stream.

Note: Scenes are automatically placed at the nearest GOP header in the video track 

when they are inserted or when their position is edited. When placing scenes, they must 

not overlap with subtitles (a violation of the DVD-Video Specification).

4 To fine-tune the scene location, select its thumbnail and edit the Scene Time field in the 

Property Browser so it is exactly 00:01:04:20. This will ensure that the scene does not 

overlap any of the subtitles in the subtitle stream.

5 Repeat the previous steps to add an additional scene at precisely 00:01:58:00.

The Sl ide Show Track

This section documents how to create the tutorial’s Slide Show track, which will consist of 

four still images (A, B, C, and D) that will each display for 10 seconds. The Slide Show track 

will also contain an audio stream that will play as the slides are displayed.

To create the slide show track:

1 In the Scenarist main window, click the Track Editor tab to display the Track Editor.

2 In the Asset Manager, click the Data tab to display the project’s assets.

3 In the Asset Manager, open the Slides folder to display the project’s slide assets.



The Slide Show Track 19
4 Drag Slide_A from the Asset Manager into the Tracks folder in the Track Editor directory 

area. This will be the first slide in the track.

5 When prompted, select Slide Show and click OK. A slide show track is created. 

6 In the Track Editor directory, select the Slide-A-t track. The timeline displays the first slide 

image in the still stream at the beginning of the track. The default duration for new slides 

is 10 seconds.

7 Drag Slide_B from the Asset Manager into the still stream, to the right of the first slide 

image. Newly added slides have the same duration as the slide preceding them in the 

track.
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8 Drag Slide_C from the Asset Manager into the still stream, to the right of Slide_B, then 

drag slide Slide_D into the still stream, to the right of Slide_C.

9 In the Asset Manager, open the Audio folder to display the project’s audio assets.

10 Drag Slide_Show_Audio from the Asset Manager into the timeline area, just below the 

still stream. The audio stream is added to the track.

The Main Menu

The Main Menu will appear after the Intro Movie plays and provide links to the disc’s 

content. In this section you will build the Main Menu track (a motion menu) from a video 

asset for the background layer, and a subpicture asset for the overlay layer. You will also add 

button highlights that will eventually be linked to the Main Movie, Slide Show, Chapter 

Menu, and DVD Credits.

This section includes the following topics:

• “Creating the Main Menu Track” on page 21

• “Adding Button Highlights to the Main Menu” on page 22

• “Setting the Highlight Colors for the Main Menu” on page 23
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Creating the Main Menu Track

To create the Main Menu track:

1 In the Scenarist main window, click the Track Editor tab to display the Track Editor.

2 In the Asset Manager, click the Data tab to display the project’s assets.

3 Drag Main_Menu from the Asset Manager into the Tracks folder in the Track Editor 

directory area. A video track is created.

4 In the Track Editor directory area, select the Main_Menu-t track. The timeline displays the 

track’s video and scenes streams.

5 In the Asset Manager, open the Subpicture folder to display the tutorial’s subpicture 

assets. 

6 Drag Main_Menu_Sub from the Asset Manager into the timeline area, just below the 

video stream. Subpicture and highlight streams are added to the track.
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Adding Button Highlights to the Main Menu

The Main Menu background layer contains text for four buttons, and the overlay layer 

contains four triangles that will change color depending on the state of the buttons (normal, 

selected, or activated). In this section you will add the Main Menu’s button highlights and 

button links (for remote control selection).

To add button highlights to the Main Menu track:

1 Select the Main_Menu-t track in the Track Editor directory area.

2 Select View > Simulation Window. The Simulation window opens displaying the first 

frame of the Main_Menu-t track.

3 For greater precision when creating button highlights, set the Simulation window to 

normal size. Deselect Mode > Half Size, or deselect the Half Size button in the Mode 

palette.

4 Button highlights can only be added in Design mode. In the Mode palette, select the 

Design Mode button.

5 In the Design Tools palette, select the New Button tool.

6 Create a button highlight by dragging a rectangle around the Play Movie button. Make 

sure the highlight completely contains the text and triangles, but does not overlap the 

button below. The first highlight created is Button 1 and will be the default button 

selected when the viewer enters the menu.
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7 In the Design Tools palette, select the Select tool and use it to adjust the placement and 

size of the button highlight as necessary. Click the button highlight and drag its edges to 

resize it, or drag from the middle of the button highlight to move it.

Note: Scenarist also has commands for automatically resizing and aligning button 

highlights. For more information, see Chapter 8, “Creating Menu Tracks” in the Scenarist 

User Guide.

8 Repeat the previous steps to create highlights for the remaining buttons.

9 Choose Tools > Auto Route. Button links are added that will allow the viewer to navigate 

and select the buttons by pressing the ARROWS on the remote control.

When the viewer enters the Main Menu, the Play Movie button (Button 1) will be selected 

by default. Clicking the DOWN arrow on the remote control will select the next button 

below it, and so forth. Clicking the UP arrow will select the previous button above it. If the 

DVD Credits button is selected, clicking the DOWN arrow will loop back to highlight the 

Play Movie button.

Setting the Highlight Colors for the Main Menu

In this section you will set the Highlight Colors for the Main Menu, so that the triangles on 

the subpicture layer will change color to indicate the button states. When displayed 

normally, the triangles will be invisible; when selected, they will turn gray; when activated, 

they will turn red.
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To set the highlight colors for the Main Menu track:

1 Select the Main_Menu-t track in the Track Editor directory area.

2 If the Simulation window is not open, select View > Simulation Window.

3 In the Simulation window, click the Subpicture and Highlight tab, then scroll to the 

Colors page with the Left-Right arrows (on the right side of the tab). 

4 Select Mode > Display Color. The Simulation window displays the default colors for the 

button highlights, how they will appear when not selected and not activated.

5 Leave the Display Color for Color 3 set to Black. Set its Contrast value to 0% by clicking 

the Down arrow, to the right of the color, repeatedly. As the Contrast value decreases, 

the button triangles decrease in opacity until they are completely transparent.

6 Select Mode > Selection Color. The Simulation window displays the Selection Colors for 

the button highlights, how they will appear when selected.

7 Click the Selection Color for Color 3 and select Light Gray from the pop-up color palette. 

The button triangles are displayed in light gray. Set its Contrast value to 60%.

8 Select Mode > Action Color. The Simulation window displays the Action Colors for the 

button highlights, how they will appear when activated.

9 Click the Action Color for Color 3 and select Red from the pop-up color palette. The 

button triangles are displayed in red. Set its Contrast value to 60%.
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The Chapter  Menu

The Chapter Menu will provide links to the three scenes in the Main Movie. In this section 

you will build the Chapter Menu track (a motion menu) from a video asset for the 

background layer, and a subpicture asset for the overlay layer. You will also add button 

highlights that will eventually be linked to the Main Movie.

This section includes the following topics:

• “Creating the Chapter Menu Track” on page 25

• “Adding Button Highlights to the Chapter Menu” on page 26

• “Setting the Highlight Colors for the Chapter Menu” on page 27

Creating the Chapter Menu Track

To create the Chapter Menu track:

1 In the Scenarist main window, click the Track Editor tab to display the Track Editor.

2 In the Asset Manager, click the Data tab to display the project’s assets.

3 Drag Chapter_Menu from the Asset Manager into the Tracks folder in the Track Editor 

directory area. A video track is created.

4 In the Track Editor directory area, select the Chapter_Menu-t track. The timeline displays 

the track’s video and scenes streams.

5 In the Asset Manager, open the Subpictures folder to display the project’s subpicture 

assets.

6 Drag Chapter_Menu_Sub from the Asset Manager into the timeline, just below the video 

stream. Subpicture and highlight streams are added to the track.
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Adding Button Highlights to the Chapter Menu

The Chapter Menu background layer contains thumbnails for the three movie scenes. The 

overlay layer contains three rectangles and a Back button that will change color depending 

on the state of the buttons (normal, selected, or activated). In this section you will add the 

Chapter Menu’s button highlights and button links (for remote control selection).

To add button highlights to the Chapter Menu track:

1 Select the Chapter_Menu-t track in the Track Editor directory area.

2 If the Simulation window is not open, select View > Simulation Window.

3 For greater precision when creating button highlights, set the Simulation window to 

normal size. Deselect Mode > Half Size, or deselect the Half Size button in the Mode 

palette.

4 Button highlights can only be added in Design mode. In the Mode palette, select the 

Design Mode button.

5 From the Design Tools palette, select the New Button tool.

6 Create a button highlight by dragging a rectangle around the left rectangle (the button 

for Scene 1 in the Main Movie). Make sure the highlight completely contains the 

rectangle, but does not overlap the button to the right. The first button created is 

Button 1 and will be the default button selected when the viewer enters the menu.
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7 In the Design Tools palette, select the Select tool and use it to adjust the placement and 

size of the button highlight as necessary. Click the button highlight and drag its edges to 

resize it, or drag from the middle of the button highlight to move it.

Note: Scenarist also has commands for automatically resizing and aligning button 

highlights. For more information, see Chapter 8, “Creating Menu Tracks” in the Scenarist 

User Guide.

8 Repeat the previous steps to create button highlights for the other two scenes and the 

Back button.

9 Choose Tools > Auto Route. Button links are added that will allow the viewer to navigate 

and select the buttons by pressing the ARROWS on the remote control.

When viewer enters the Chapter Menu, the Scene 1 button on the left (Button 1) will be 

selected by default. The LEFT and RIGHT arrows on the remote control will select each of the 

buttons in succession and loop eventually back to Button 1.

Setting the Highlight Colors for the Chapter Menu

In this section you will set the Highlight Colors for the Chapter Menu, so that the rectangles 

and the Back button on the subpicture layer will change color to indicate the button states. 

When displayed normally, the rectangles will be invisible and the Back button will be black; 

when a button is selected, it will turn gray; when a button is activated, it will turn red.
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To set the highlight colors for the Chapter Menu track:

1 Select the Main_Menu-t track in the Track Editor directory area.

2 If the Simulation window is not open, select View > Simulation Window.

3 In the Simulation window, click the Subpicture and Highlight tab, then scroll to the 

Colors page with the Left-Right arrows (on the right side of the tab).

4 Select Mode > Display Color. The Simulation window displays the default colors for the 

button highlights, how they will appear when not selected and not activated.

5 Leave the Display Color for Color 3 set to Black. Set its Contrast value to 0% by clicking 

the Down arrow, to the right of the color, repeatedly. As the Contrast value decreases, 

the button rectangles decrease in opacity until they are completely transparent.

6 Click the Display Color for Color 2 and select Black from the pop-up color palette. The 

Back button is displayed in black. Leave its Contrast value set to 100%. 

7 Select Mode > Selection Color. The Simulation window displays the Selection Colors for 

the button highlights, how they will appear when selected.

8 Click the Selection Color for Color 3 and select Light Gray from the pop-up color palette. 

The button rectangles are displayed in light gray. Set its Contrast value to 60%.

9 Click the Selection Color for Color 2 and select Light Gray from the pop-up color palette. 

The Back button is displayed in light gray. Set its Contrast value to 80%.

10 Select Mode > Action Color. The Simulation window displays the Action Colors for the 

button highlights, how they will appear when activated.

11 Click the Action Color for Color 3 and select Red from the pop-up color palette. The 

button rectangles are displayed in red. Set its Contrast value to 60%.

12Click the Action Color for Color 2 and select Red from the pop-up color palette. The 

Back button is displayed in red. Set its Contrast value to 60%.
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The DVD Credi ts  Menu

In the following section you will build the DVD Credits menu from a Photoshop file that 

contains a background layer and button layer (containing a single Back button).

Scenarist can create menu tracks from Photoshop files that contain background and button 

layers. When importing the Photoshop file, the button layers are composited to the 

background layer, and subpicture and highlight information, based on the button shapes, is 

automatically generated. Preparing menus in Photoshop allows you to make sure the button 

graphics are positioned correctly over the background before you import them to Scenarist.

To create the DVD Credits Menu track:

1 In the Scenarist main window, click the Track Editor tab to display the Track Editor.

2 In Windows Explorer, open the Scenarist Tutorial Assets folder copied to your hard drive.

3 Drag DVD_Credits.psd from Windows Explorer into the Tracks folder in the Track Editor 

directory area. You are prompted to specify what kind of still track you want to create.

4 Select Still Menu with Sub-picture and click OK. The Select Layers dialog opens, 

displaying the background and subpicture images on the left, and the button layers on 

the right.
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5 In the Layer section, make sure the Button 1 layer is selected, so its Eye icon appears.

6 Click OK. The background and button layers are flattened and imported as a still image 

background asset, which is placed in a new still track. The button layer is imported as a 

still image subpicture asset, which is used to generate subpicture and highlight streams 

for the new still track.

7 Select the DVD_Credits-t track in the Track Editor directory area.

8 If the Simulation window is not open, select View > Simulation Window.

9 At the bottom of the Simulation window, click the Subpicture and Highlight tab, then 

scroll to the Colors page with the Left-Right arrows (on the right side of the tab).

10 Select Mode > Selection Color. The Simulation window displays the Selection Colors for 

the Back button, how it will appear when selected.
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11 Click the Selection Color for Color 2 and select Black from the pop-up color palette. The 

Back button is displayed in black. Leave its Contrast value set to 100%. 

12Select Mode > Action Color. The Simulation window displays the Action Colors for the 

Back button, how it will appear when activated.

13Click the Action Color for Color 3 and select Red from the pop-up color palette. The 

Back button is displayed in red. Set its Contrast value to 60%.
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4   Adding Navigation to the Tutorial

This chapter documents how to author navigation for the tutorial project by creating PGCs 

and adding links between them. It includes the following topics:

• “Adding PGCs to the Tutorial” on page 34

• “Directing Playback in the Tutorial” on page 40

• “Linking the Button Highlights” on page 44
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Adding PGCs to  the Tutor ial

Program chains (PGCs) contain the playback characteristics and navigation information for 

the disc’s content, determining the order in which tracks are played and how menus are 

linked to other menus and tracks. A PGC is required for each menu, video, and still track in 

the scenario. PGCs are represented by a vertical string of icons in the Scenario Editor 

authoring area.

In the following sections you will create PGCs by dragging the previously created tutorial 

tracks into language and title folders in the Scenario Editor. 

• “Adding PGCs to the Video Manager” on page 34

• “Adding PGCs to VTS_1” on page 37

• “Arranging the Tutorial PGCs in the Authoring Area” on page 39

Adding PGCs to the Video Manager

In this section you will add a Language folder to the Video Manager and add PGCs for the 

Main Menu, DVD Credits menu, and Intro Movie. 

The Language folder in the Video Manager contains the project’s title menu, which serves as 

a top-level menu through which the viewer can access the titles and other menus on the 

disc. This Language folder can also contain other menus (submenus), as well as introductory 

titles.

To add PGCs to the Video Manager:

1 In the Asset Manager, click the Tracks tab to display the project’s tracks.
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2 In the Scenario Editor authoring area, Right-click the Video Manager folder and choose 

Add Language from the pop-up menu. When prompted, select English and click OK. The 

Language folder is added.

3 Drag Main_Menu-t from the Asset Manager into the Video Manager Language folder in the 

authoring area. A title menu PGC is added to the Language folder. The PGC contains 

program, cell, and menu icons.

4 Drag Main_Intro-t from the Asset Manager into the Video Manager Language folder in the 

authoring area. A PGC is added to the Language folder. The PGC contains program and 

cell icons.
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5 Drag DVD_Credits-t from the Asset Manager to the Video Manager Language folder in the 

authoring area. A PGC is added to the Language folder. The PGC contains program, cell, 

and menu icons.

6 Arrange the PGCs in the Video Manager folder (by dragging them) so they look like this:
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Adding PGCs to VTS_1

In this section you will add PGCs for the Main Movie, Slide Show, and Chapter Menu to 

VTS_1. VTS (Video Title Set) folders contain title folders that contain title tracks. VTS folders 

also contain Language folders that contain the root menu and submenus for the VTS.

To add PGCs to VTS_1:

1 In the Asset Manager, click the Tracks tab to display the project’s tracks.

2 In the authoring area, Right-click VTS_1 and choose Add Language from the pop-up 

menu. When prompted, select English and click OK. A Language folder is added to 

VTS_1.

3 Position the Language folder to the left of the Title_1 folder.

4 Drag Chapter_Menu-t from the Asset Manager into the VTS_1 Language folder in the 

authoring area. A root menu PGC is added to the Language folder. The PGC contains 

program, cell, and menu icons.
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5 Drag Main_Movie-t from the Asset Manager into the Title_1 folder in the authoring area. A 

title entry PGC is added to the folder. The Main_Movie PGC contains a program and cell 

icon for each of its three scenes.

6 In the authoring area, Right-click VTS_1 and choose Add Title from the pop-up menu. 

When prompted, enter “Title_2” for the name and click OK. A title folder is added to 

VTS_1.

7 Position the Title_2 folder to the right of the Title_1 program and cell icons.

8 Drag Slide_A-t from the Asset Manager into the Title_2 folder in the authoring area. A PGC 

is added to the folder. The PGC contains program and cell icons.
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Arranging the Tutorial PGCs in the Authoring Area

When authoring in the Scenario Editor, it is helpful to logically arrange the folders and PGC 

icons in the authoring area, to represent the project flow. This is especially useful when you 

begin linking the different elements in the project. When you drag a folder or PGC icon in 

the authoring area, its contents below it are moved with it, while retaining their existing 

nested layout.

Before moving on to the next sections, where you will add links to the tutorial project, first 

arrange the PGC icons as they are in Figure 3. When arranging PGC icons, you may find it 

necessary to zoom out in the authoring area (choose View > Zoom Out).

For more information on organizing the authoring area, including aligning and collapsing 

PGC icons, and displaying PGC icons with thumbnails, see Chapter 10, “Authoring in the 

Scenario Editor” in the Scenarist User Guide.

Figure 3: PGC icons arranged for the tutorial project
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Direct ing Playback in  the Tutor ial

In the following sections you will set the playback order for the project by adding Jump 

commands to the PGCs in the Scenario Editor authoring area:

• “Setting the First PGC” on page 40

• “Specifying What Plays Next” on page 42

• “Looping the Main Menu and Chapter Menu” on page 43

Setting the First PGC

We want the Intro Movie to automatically play when the completed disc is inserted into a 

DVD player. This is achieved by assigning the Intro Movie to the First PGC.

To set the First PGC for the tutorial:

1 In the Scenario Editor, select the Select tool from the Tools Bar.

2 If the Scenario Editor is not zoomed, choose View > Zoom In, or click the Zoom In 

button in the Tools Bar.

3 In the Scenario Editor authoring area, move the cursor over the Pre flag of the First PGC. 

The CMD Link cursor appears, along with a list of any existing Pre commands for the 

First PGC.
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4 Drag from the First PGC Pre flag to the Intro_Movie PGC icon (in the Video Manager 

Language). As you drag the cursor it changes to a No CMD Link cursor when not over a 

valid Jump destination; when over a valid Jump destination, it changes back to the CMD 

Link cursor.

5 When prompted, select “Set as the only pre command” and click OK. The Jump 

command is added and appears in the Scenario Editor as a pink arrow connecting the 

First PGC and the Intro_Movie PGC icon.

No CMD 
Link cursor

CMD Link 
cursor
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Specifying What Plays Next

In the following section you will use Jump commands to direct playback to the Main Menu 

after the Intro Movie, Main Movie, and Slide Show finish playing.

To set the playback order for the tutorial PGCs:

1 In the Scenario Editor, select the Select tool from the Tools Bar.

2 If the Scenario Editor is not zoomed, choose View > Zoom In, or click the Zoom In 

button in the Tools Bar.

3 In the Scenario Editor authoring area, move the cursor over the Post flag of the 

Intro_Movie PGC icon (in the Video Manager Language folder). The CMD Link cursor 

appears, along with a list of any existing Post commands for the Intro_Movie.

4 Drag from the Intro_Movie Post flag to the Main_Menu PGC icon (in the same Language 

folder). As you drag the cursor, it changes to a No CMD Link cursor when not over a 

valid Jump destination; when over a valid Jump destination, it changes back to the CMD 

Link cursor.

5 When prompted, select “Set as the only post command” and click OK. The Jump 

command is added and appears in the Scenario Editor as a pink arrow connecting the 

PGCs for the Intro_Movie and Main_Menu. The Intro_Movie Post flag turns yellow.
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6 Drag from the Main_Movie Post flag in Title_1 to the Main_Menu PGC icon (in the Video 

Manager Language folder). When prompted, select “Set as the only post command” and 

click OK. The Jump command is added.

7 Drag from the Slide_Show Post flag in Title_2 to the Main_Menu PGC icon (in the Video 

Manager Language folder). When prompted, select “Set as the only post command” and 

click OK. The Jump command is added.

Looping the Main Menu and Chapter Menu

In the following section we will use Jump commands to loop the Main Menu and Chapter 

Menu. This will allow the video backgrounds for these menus to play continuously until the 

viewer selects and activates a menu button. You will also have to set the Forced Selected 

option for each menu so that a default button is not automatically selected when the menus 

loop back to the beginning.

To loop a PGC with a Jump command:

1 In the Scenario Editor, select the Select tool from the Tools Bar.

2 In the Scenario Editor authoring area, move the cursor over the Main_Menu Post flag (in 

the Video Manager Language folder). The CMD Link cursor appears, along with a list of 

any existing Post commands in the PGC.

3 Drag from the Post flag back to its own PGC icon. The Jump command is added to the 

PGC and appears as a pink arrow pointing back to itself; the Post flag turns yellow.

4 Repeat the previous steps to loop the Chapter Menu (in the VTS_1 Language folder).

5 Set the Forced Selected option for the Chapter Menu:

• Select the Chapter_Menu PGC icon in the authoring area.
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• If the Simulation window is not open, select View > Simulation Window.

• At the bottom of the Simulation window, click the Subpicture and Highlight tab, then 

scroll to the Highlight page with the Left-Right arrows (on the right side of the tab).

6 If necessary, scroll to the bottom of the Edit area in the Simulation window, then set the 

Forced Selected option to Nonexistent:

7 Repeat the previous steps to set the Forced Selected option for the Chapter Menu.

Linking the But ton Highl ights

In the following sections you will set the destinations for the each of the menu buttons:

• “Linking the Main Menu Buttons” on page 45

• “Linking the Chapter Menu Buttons” on page 47

• “Linking the DVD Credits Back Button” on page 48
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Linking the Main Menu Buttons

In this section you will link the Main Menu buttons to the Main Movie, Chapter Menu, Slide 

Show, and DVD Credits Menu.

To link the button highlights in the Main Menu:

1 In the Scenario Editor, select the Select tool from the Tools Bar.

2 If the Scenario Editor is not zoomed, choose View > Zoom In, or click the Zoom In 

button in the Tools Bar.

3 In the Scenario Editor authoring area, move the cursor over the Btns flag of the 

Main_Menu icon (in the Video Manager Language folder). The CMD Link cursor appears, 

along with a list of button commands in the menu PGC.

4 Drag from the Btns flag to the Title_1 folder (in VTS_1). As you drag, the cursor changes 

to a No CMD Link cursor when not over a valid Jump destination; when over a valid 

Jump destination, the cursor changes back to the CMD Link cursor.

No CMD 
Link cursor

CMD Link 
cursor
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5 When prompted with the Choose Command Button dialog, click the Play Movie button 

highlight. The Jump command is added and appears in the Scenario Editor as a pink 

arrow connecting the source and destination. The Btns flag of the source menu turns 

yellow.

6 Drag from the Main_Menu Btns flag to the Chapter_Menu PGC icon (in the VTS_1 

Language folder). In the Choose Command Button dialog, click the Chapter Selection 

button highlight. The Jump command is added.

7 Drag from the Main_Menu Btns flag to the Title_2 folder (in VTS_1). In the Choose 

Command Button dialog, click the Slide Show button highlight. The Jump command is 

added.

8 Drag from the Main_Menu Btns flag to the DVD_Credits PGC icon (in the Video Manager 

Language folder). In the Choose Command Button dialog, click the DVD Credits button 

highlight. The Jump command is added.
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Linking the Chapter Menu Buttons

In this section you will link the Chapter Menu buttons to the three scenes in the Main 

Movie. You will also link the Back button to the Main Menu.

To link the button highlights in the Chapter Menu:

1 In the Scenario Editor, select the Select tool from the Tools Bar.

2 If the Scenario Editor is not zoomed, choose View > Zoom In, or click the Zoom In 

button in the Tools Bar.

3 In the Scenario Editor authoring area, move the cursor over the Btns flag of the 

Chapter_Menu icon (in the VTS_1 Language folder). The CMD Link cursor appears, along 

with a list of button commands in the menu PGC.

4 Drag from the Btns flag to the first Main_Movie program icon (Main_Movie-scn-pg). As 

you drag, the cursor changes to a No CMD Link cursor when not over a valid Jump 

destination; when over a valid Jump destination, the cursor changes back to the CMD 

Link cursor.

5 When prompted with the Choose Command Button dialog, click the button highlight for 

the left rectangle. The Jump command is added and appears in the Scenario Editor as a 

pink arrow connecting the source and destination. The Btns flag of the source menu 

turns yellow.

6 Drag from the Chapter_Menu Btns flag to the second Main_Movie program icon 

(Main_Movie-scn_1-pg). In the Choose Command Button dialog, click the button 

highlight for the center rectangle. The Jump command is added.

No CMD 
Link cursor

CMD Link 
cursor
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7 Drag from the Chapter_Menu Btns flag to the second Main_Movie program icon 

(Main_Movie-scn_2-pg). In the Choose Command Button dialog, click the button 

highlight for the right rectangle. The Jump command is added.

8 Drag from the Chapter_Menu Btns flag to the Main_Menu PGC icon (in the Video 

Manager Language folder). In the Choose Command Button dialog, click the Back button 

highlight. The Jump command is added.

Linking the DVD Credits Back Button

In this section you will link the Back button in the DVD Credits menu to the Main Menu.

To link the Back button in the DVD Credits menu:

1 In the Scenario Editor, select the Select tool from the Tools Bar.

2 If the Scenario Editor is not zoomed, choose View > Zoom In, or click the Zoom In 

button in the Tools Bar.

3 In the Scenario Editor authoring area, move the cursor over the Btns flag of the 

DVD_Credits icon. The CMD Link cursor appears, along with a list of button commands 

in the menu PGC.

4 Drag from the Btns flag to the Main_Menu PGC icon (in the Video Manager Language 

folder). As you drag, the cursor changes to a No CMD Link cursor when not over a valid 

Jump destination; when over a valid Jump destination, the cursor changes back to the 

CMD Link cursor.

5 When prompted with the Choose Command Button dialog, click the Back button 

highlight. The Jump command is added and appears in the Scenario Editor as a pink 

arrow connecting the source and destination. The Btns flag of the source menu turns 

yellow.

Now that you’ve added the navigation links to the tutorial, you are ready to proof it in 

Simulation mode, and then output to disc or DLT.
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This chapter documents how to test the tutorial project and output it to disc or tape. It 

includes the following topics:

• “Simulating the Tutorial Project” on page 50

• “Outputting the Tutorial Project” on page 53

• “Conclusion” on page 56



50 Chapter 5, Outputting the Tutorial Project
Simulat ing the Tutor ial  Project

In this section you will proof the tutorial project in Simulation mode. Simulation mode lets 

you fully test a project before committing to writing the disc image. The controls in 

Scenarist’s Simulation window are designed to behave just like a real DVD player so you can 

interact with the project as if it were a finished disc. 

If you have a CineMaster C3.0 Decoder card or Matrox Parhelia card, you can use Hardware 

Simulation to route video to an external video monitor. When using Software Simulation, the 

video is displayed only in the Simulation window in Scenarist.

This section includes the following topics:

• “Multiplexing the Project” on page 50

• “Simulating the Project” on page 51

Multiplexing the Project

Before a track with subtitles or subpicture effects can be played in Software Simulation 

mode, it must first be multiplexed. Before a project can be played in Hardware Simulation 

mode, the entire project must be multiplexed. Multiplexing is the process of combining a 

track’s video, audio, and subpicture streams into a single data stream. In the following 

procedure, you will multiplex the entire tutorial project.

To multiplex the tutorial project:

• In the Scenarist main window, choose Tools > Multiplex > All. The project is multiplexed 

with data streams written for each track. Progress messages appear in the Build tab of 

the Information window.

Note: You can multiplex an individual track by selecting the track in the Track Editor and 

choosing Tools > Multiplex > Track.
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Simulating the Project

In this section you will simulate the project and test its navigation.

To the proof the tutorial project in Simulation mode:

1 In the Scenario Editor directory area, select the First PGC icon.

2 If the Simulation window is not open, select View > Simulation Window.

3 In the Simulation window, deselected Mode > Half Size. The Simulation Window preview 

area is displayed in full size.

4 Do one of the following:

• To enable Software Simulation, click the Software Simulation button in the Mode palette. 

• To enable Hardware Simulation, click the Hardware Simulation button in the Mode 

palette. This option is only available if you have installed and configured a 

CineMaster C3.0 or Matrox Parhelia.
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5 Use the Remote Control buttons in the Design Tools palette and Player Settings palette to 

interact with the project as if you were a viewer.

• Click the Play button and make sure the Intro Movie plays and that the Main Menu 

follows.

• Use the SELECTION ARROWS to navigate the buttons on the Main Menu. Click the ENTER 

button to activate a selected button. Test the four Main Menu buttons to verify that they 

link to the Main Movie, Chapter Menu, Slide Show, and DVD Credits menu. Click the 

TITLE button to return to the Main Menu.
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• When playing the Main Movie, click the SKIP FORWARD and SKIP BACKWARD buttons to 

move between the three chapter points. Click the SUBPICTURE ON/OFF button to turn off 

and on the subtitles. Click the MENU button to jump to the Chapters Menu.

• In the Chapters Menus, verify that the three movie buttons link correctly to the three 

chapter points in the Main Movie, and that their Highlight Colors are suitable.

• Play the Slide Show and make sure that after the four slides are displayed that the Main 

Menu appears.

• View the Credits Menu and click the Back button to return to the Main Menu.

6 To exit Simulation mode, click the Stop button in the Design Tools palette and then click 

the Design Mode button in the Mode palette.

Make any necessary changes to the project and then proof it again. Once you are happy 

with the results, you are ready to output the project to disc or DLT.

Output t ing the Tutor ial  Project

Once you have thoroughly tested the project’s navigation, playback quality, and 

synchronization, you are ready to write the project to CD-R for playback on computers, 

DVD-R for playback on both computers and set-top DVD players, or DLT for mass 

replication.

This section includes the following topics:

• “Outputting to CD-R or DVD-R” on page 54

• “Outputting to DLT” on page 55

Note: For information on adding copy protection, parental levels, region management, and 

volume information to projects, see Chapter 16, “Copy Protection and Premastering” in the 

Scenarist User Guide.
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Outputting to CD-R or DVD-R

If you want to create just a few copies of your project for playback in consumer set-top DVD 

players, as well as on computers, you can output the project to DVD-R media. You can also 

output the project to CD-R media for playback on computers.

Note: DVD players may not support playback from CD-R or DVD-R media. If the disc you 

create is not recognized by your player, or exhibits break-up of the video or audio during 

playback, consult the player’s manufacturer regarding support for CD-R or DVD-R media.

To output the tutorial project to CD-R or DVD-R:

1 Click the Layout Editor tab to display the Layout Editor.

2 In the Step 1 section of the Layout Editor, set the Format menu to DVD Video.

3 In the Step 2 section of the Layout Editor, click the Target Directory Browse button and 

select a folder on a local hard drive (not on a network server) that has enough available 

space for the project, then click OK. The selected folder is displayed in the Target 

Directory field and subfolders for DVD Root, and Mux are automatically set.

Note: If you want to automatically delete the DVD Root or Mux files after the disc 

image is written (to conserve hard drive space), select the appropriate Delete When 

Done option.

4 In the Step 3 section of the Layout Editor, select all three options: Create DVD Video, 

Create Disc Image, and Premastering.

5 Make sure your CD-R or DVD-R recorder is selected in the Target Device menu. Scenarist 

supports a wide variety devices. If your device is supported and properly connected and 

powered on, Scenarist will automatically recognize it.

6 Click Start to begin outputting the project. The Information window displays the status 

and progress for the output operations that were specified:

• Project data is prepared and multiplexed and written to the Mux Directory.

• DVD files are generated (VIDEO_TS folder) and written to the DVD Root Directory.
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• The Disc image file is written to the Target Directory.

• The Disc image file is output to the Target Device.

7 When prompted, insert a disc in your CD-R or DVD-R recorder.

8 To interrupt the output process, click Cancel in the Information window.

9 When you are prompted that Layout is complete, click OK.

Outputting to DLT

If you want to have your project manufactured on a large scale, you can output it to digital 

linear tape (DLT) and send it to a DVD replicator for mass production. DLTs are the standard 

for delivering DVD content for replication.

To output the tutorial project to DLT:

1 Click the Layout Editor tab to display the Layout Editor.

2 In the Step 1 section of the Layout Editor, set the Format menu to DVD Video.

3 In the Step 2 section of the Layout Editor, click the Target Directory Browse button and 

select a folder on a local hard drive (not on a network server) that has enough available 

space for the project, then click OK. The selected folder is displayed in the Target 

Directory field and subfolders for DVD Root, and Mux are automatically set.

Note: If you want to automatically delete the DVD Root or Mux files after the disc 

image is written (to conserve hard drive space), select the appropriate Delete When 

Done option.

4 In the Step 3 section of the Layout Editor, select all three options: Create DVD Video, 

Create Disc Image, and Premastering.

5 If you have previously output the project

6 Make sure your DLT drive is selected in the Target Device menu. Scenarist supports a 

wide variety devices. If your device is supported and properly connected and powered 

on, Scenarist will automatically recognize it.
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7 Set the Premastering Mode to Dump and set the Tape Format to either DDP 2.0 or MID 

(check with your disc replication facility to see which tape format is required).

8 Click Start to begin outputting the project. The Information window displays the status 

and progress for the output operations that were specified:

• Project data is prepared and multiplexed and written to the Mux Directory.

• DVD files are generated (VIDEO_TS folder) and written to the DVD Root Directory.

• The Disc image file is written to the Target Directory.

• The Disc image file is output to the Target Device.

9 When prompted, insert a tape in your DLT drive.

10 To interrupt the output process, click Cancel in the Information window.

11 When you are prompted that Layout is complete, click OK.

Conclusion

Once you have output the project to CD-R, DVD-R, or DLT, the tutorial is complete. After 

you’ve had a chance to review the final disc, you might want to go back and try a few more 

things, such as:

• Add more subtitles to the feature video using Scenarist’s built-in subtitle generator.

• Change the project flow so that the Main Menu jumps to the Main Move when it times 

out, rather than simply looping.

• Experiment with different highlight colors, or even create your own subpictures for the 

menus.

• Add additional subtitle languages or audio streams in order to familiarize yourself with 

Scenarist’s multi-lingual capabilities.
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